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4 Poglavlje 1 • Uvod u OpenOffice.org

 

Kratak vodiå kroz OpenOffice.org

 

OpenOffice.org je vaãa besplatna karta za voæçu vozom Microsoft Office. On otvara sve tipove 
datoteka Microsoft Officea –Word, Excel i PowerPoint. Bilo koju datoteku moæete snimiti u 
bilo kom od ovih formata. Napraviñete nov Microsoftov dokument za tekst, tabelu ili prezen-
taciju bez koriãñeça Microsoftovih programa. 

 

Vlade, mala preduzeña, ãkole i svi drugi korisnici

 

   Svako moæe da zavrãi svoj projekat a da ne 
potroãi odjednom 500 USD. Samo treba preñi na program OpenOffice. 

 

Koristi iste formate i prevazilazi Microsoft Office

 

   Open-
Office otvara desetine drugih datoteka, npr. Lotus 
1-2-3, i formata, npr. GIF, SVG i PNG grafiku i savr-
ãeno manipuliãe çima. Ne samo da je omoguñeno da 
otvorite i izmenite sve datoteke kao i u Microsofto-
vim programima, nego imate i dodatne moguñnosti. 

 

Prelazak s Microsoft Officea na OpenOffice  

 

 Ako ste 
korisnik MS Officea, morañete malo i da uåite, ali 
ñete tokom uåeça åesto govoriti: “O, pa ovo je isto”. 

 

Grafika na profesionalnom nivou   

 

Postoji joã jedna 
prednost. Uz program OpenOffice dobijate Draw, 
izvrstan program za obradu crteæa i slika, koji po 
moguñnostima uveliko prevazilazi siromaãne alatke 
iz Microsoft Officea. Draw je odliåan program, neãto 
jednostavniji od Adobeovih proizvoda, ali snaæan i s 
mnogo moguñnosti. Omoguñava izvoæeçe u formate 
EPS, SVG i niz drugih grafiåkih formata, ukàuåujuñi 
i standarde kao ãto su GIF i JPG.

 

Kako poåeti

 

   Da biste saznali viãe o paketu OpenOffice.org i novinama u odnosu na StarOffice, 
proåitajte odeàke 

 

Osnove programa

 

 i 

 

Ãta je novo

 

 na strani 6, odnosno 11. Ukoliko æelite da 
odmah instalirate program, preœite na poglavàe 2.

 

Deset glavnih razloga za koriãñeçe programa OpenOffice.org

 

Evo deset najboàih razloga da preœete na OpenOffice.

 

1

 

Program OpenOffice je besplatan. Microsoft Office je mnogo skupài, koãta i do 550 USD. 
Najboàe od svega je ãto na OpenOffice ne utiåe Microsoftova politika cena, distribucije, 
licenciraça i dominacije u svetu uopãte. 

 

2

 

Vladine organizacije izdaju obrasce u formatima programa Word i Excel. Univerziteti traæe 
da studenti predaju svoje pismene radove u Wordovom formatu. Åak i osnovne ãkole piãu 
svoje jelovnike u tom formatu. Ko æeli da plati 550 USD da bi proåitao jelovnik? Samo 
nabavite OpenOffice. I ako vam ne budu trebale mnoge moguñnosti ovog programa, moñi 
ñete da åitate sve iz zatvorenog sveta Microsofta, a da ne æivite u çemu.
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Da li ste imali problema s kompatibilnoãñu s prethodnim verzijama? Imate datoteke iz 
paketa Office 97 koje ne moæete da otvorite u sadaãçoj verziji MS Officea? Takvih prob-
lema nema s programima OpenOffice ili StarOffice; oni su kompatibilniji s MS Officeom 
nego sam MS Office.

 

4

 

Joã neãto: ovo je zvaniåno. Bil Gejts ima dovoàno novca. A vi? Ukoliko vi i vaãa deca u 
osnovnoj ãkoli, ili na fakultetu, vaãa mala preduzeña, sredça preduzeña, korporacije, obra-
zovna ustanova, crkva, sinagoga, biblioteka, vladina organizacija, advokatska kancelarija, 
sportski savez, dobrovoàna organizacija, ili lanac poslastiåarnica imate dovoàno novca 
– sjajno. Ali ako nemate, novac vam je potrebniji nego Bilu. Ãtedite, i poånite da koristite 
OpenOffice umesto programa iz srodnih komercijalnih paketa. 

 

5

 

OpenOffice ima najboài program za crtaçe koji ste ikada koristili. Ima 3D alatke na koje 
niste naiãli u Wordovoj opremi za crtaçe. To su vizuelne alatke za arhitektonske projekte 
i elektriåne ãeme, zgodne linije za automatsko mereçe koje prikazuju dimenzije svakog 
objekta na crteæu (u odnosu 1:1 ili u razmeri). Tu je i program FontWorks koji izvrsno 
manipuliãe tekstom, kao i moguñnost obrade fotografija u svim aplikacijama. Pogledajte 
poglavàe 29, 

 

Crtaçe

 

.

 

6

 

Nema viãe zbrke zbog izvora podataka pri formiraçu cirkularnih pisama (npr. kad ãaàete 
cirkular stotinama osoba iz svog adresara). Samo vam treba lista klijenata u tekstualnoj 
datoteci ili nekoj drugoj. Sve ostalo ide neverovatno glatko i lako. Da bismo dokazali ovu 
tvrdçu, priloæili smo i uputstvo u poglavàu 35.

 

7

 

Korisnici Unixa, pravo uzbuœeçe je pred vama. Applix i druge najbitnije stare alatke, uvek 
su ograniåeno delovale. Svako ko nije strastan korisnik LaTeK-a, moæe da odahne. Unix-
ovci sada mogu da se liãe Windowsa 24/7, i ne treba im rezervni sistem kojim se pokreñe 
prezentacija u PowerPointu.

 

8

 

Datoteke OpenOfficea verovatno su najmaçe koje ñete ikada napraviti. One viãe nisu u 
binarnom formatu (kao mnoge druge aplikacije za stone raåunare), nego su u formatu XML, 
pa druge aplikacije mogu da ih otvore i rade s çima. To znaåi da moæete pisati i pisati i 
uvoziti sve vrste grafika, a vaãa datoteka ñe i daàe biti mala. Mi smo napisali neke tekstove 
u programu Writer 6.0 na pribliæno 80 strana, a datoteka je i daàe zauzimala maçe od 100 
KB. Impress, Draw i Calc takoœe prave veoma male datoteke.

 

9

 

Koje god neprijatnosti da ste imali sa programom StarOffice, zaboravite ih.

 

10

 

Koncepcija OpenOfficea je sjajna i veñ je uveliko prihvañena. Otvoreni standardi. Format 
datoteka XML. Niko nikog ne davi. Niko iz Redmonda ne kontroliãe ãta radite. Ovako treba 
praviti program. Tako je i napravàen.
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6 Poglavlje 1 • Uvod u OpenOffice.org

 

Osnove programa

 

OpenOffice.org je zaokru-
æen komplet kancelarijskih 
programa koji koristite 
za pravàeçe tekstualnih 
dokumenata, Web stranica, 
radnih tabela, prezentacija 
crteæa i slika. Ima tri spe-
cifiåne karakteristike. Radi 
s formatima Microsoft 
Officea, kao i sa blizu 200 
drugih formata. Njegova 
cena je zanemaràiva 
u odnosu na Microsoft 
Office. Radi pod Linuxom, 
Lindowsom i Solarisom, 
kao i pod Microsoftovim 
Windowsom. Svakome ko 
je imao iskustva s Microsoftovim cenama i propisima, OpenOffice je savrãeno reãeçe.

 

Programi i moguñnosti

 

U paketu OpenOffice.org postoje åetiri glavna 
programa: 

• Writer/Web – za izradu tekstualnih doku-
menata i Web stranica.

• Calc – za tabele.

• Impress – za prezentacije. 

• Draw – za crteæe profesionalnog kvaliteta 
(vektorsku grafiku) i obradu slika (rastersku 
grafiku).

Sledeñe moguñnosti i dodaci ugraœeni su 
u veñinu programa:

• Autopiloti, koji vode kroz proces izrade 
novog dokumenta i uvoz podataka iz drugih formata.

• Dijagrami i formule.

• Moguñnost povezivaça sa izvorima podataka radi slaça cirkularne poãte i pristup posto-
jeñim bazama podataka.
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• Izuzetno male datoteke for-
mata XML koje se lako otva-
raju u drugim programima.

• Lako, visokokvalitetno kon-
vertovaçe iz formata MSOf-
fice i drugih formata i u çih.

• HTML veze u vidu teksta ili 
komandnih dugmadi.

• Animacija u prezentacijama 
kao i animirane GIF slike.

• Programi su dostupni na 23 
jezika. Postoji i podrãka za 
azijske jezike.

U vreme kada je pisana ova 
kçiga, bilo je aktuelno izdaçe OpenOffice 1.0.1. OpenOffice.org je skoro isti kao StarOffice; 
OpenOffice 1.0 grubo odgovara programu StarOffice 6.0. OpenOffice i StarOffice nastali su od 
istog izvornog koda. Sun se u meœuvremenu orijentisao na StarOffice, a programeri otvorenog 
izvornog koda na OpenOffice. Zbog toga postoje neke razlike meœu çima, ali su u osnovi isti.

 

Dopunska izdaça s novim moguñnostima

 

Neposredno pre predavaça ove kçige u ãtampu, izaãla je podverzija 643. Glavne moguñnosti 
ukàuåuju snimaå makroa i izvorni PDF. Viãe informacija o ovoj podverziji nañi ñete na adresi: 

 

http://www.openoffice.org/dev_docs/source/643/release_notes.html

 

, a odatle ñete 
je i preuzeti.

 

Uåestvovaçe korisnika u stvaraçu OpenOfficea

 

Kada ste posledçi put od Bila Gejtsa traæili uvoœeçe neke nove moguñnosti u Microsoft Wordu 
i bili usliãeni? 

 

Kako i vi moæete uåestvovati

 

OpenOffice je program otvorenog izvornog koda, ãto znaåi da svako moæe razviti i dodati nove 
opcije. Ukoliko æelite da u programu neãto promenite, a umete da programirate, moæete i vi dati 
svoje predloge za izmene programa. Takoœe moæete uzeti uåeãñe i u izradi liste pitaça i odgo-
vori (QA) i procesu dokumentovaça. Da biste viãe saznali, posetite 

 

http://www.openof-

fice.org/contributing.html

 

 i 

 

http://www.openoffice.org/about.html

 

 

 

Upoznajte nove moguñnosti programa

 

Prijavite se na listu 

 

allfeatures@openoffice.org

 

 na adresi 

 

www.openoffice.org

 

.
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Razlike izmeœu programa StarOffice i OpenOffice

 

StarOffice 6.0 je komercijalni proizvod nameçen poslovnim organizacijama i korisnicima, dok 
je OpenOffice nameçen korisnicima besplatnih programa, nezavisnim programerima i zajednici 
poklonika otvorenog izvornog koda. 

Sun i zajednica korisnika OpenOfficea saraœuju na razvoju ovog programa. Sun potpomaæe 
razvoj OpenOfficea, plaña neke programere, i finansira odræavaçe lokacije 

 

www.openoffice.org

 

. 
Poboàãaça u programu OpenOffice primeçuju se u StarOfficeu, gde je moguñe, i obrnuto.

Slika 1-1 prikazuje isti dokument u programima StarOffice i OpenOffice. Moguñnosti su 
naåelno iste. Jedna je kàuåna razlika. U StarOfficeu postoje dodaci nezavisnih softverskih kuña, 
kao ãto je baza podataka Adabas ili filtar za WordPerfect. U OpenOfficeu ih nema ili su potpuno 
razliåiti.

 

Napomena – 

 

Moguñnost provere pravopisa je dodatna opcija u programu StarOffice. Napravile su 
je nezavisne softverske kuñe. Kako ova opcija nije mogla biti licencirana u obliku otvorenog 

 

koda, razliåita je u programu OpenOffice. Uoåiñete neke razlike ako koristite oba programa.

 

Slika 1-1   

 

Isti dokument prikazan u programima StarOffice i OpenOffice.

Radna tabela u StarOfficeu. Svi formati datuma u listi
formata na raspolagaçu su za oba programa, ãto nije
sluåaj s drugim tipovima formata, na primer, za valutu.

Ista radna tabela i prozor sa atributima ñelija
u programu OpenOffice.
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Izvorni kôd u programu OpenOffice ne ukàuåuje ceo kôd iz programa StarOffice. Najåeãñi 
razlog je ãto Sun plaña licencu nezavisnim softverskim kuñama i çihov kôd ukàuåuje u StarOf-
fice, a nema dozvolu da ga prenese u OpenOffice. U programu OpenOffice ne nalaze se sledeñe 
stavke: 

• pojedini fontovi 

• komponenta za rad s bazama podataka (Adabas D) 

• neki ãabloni (pogledajte 

 

www.ooextras.org

 

,

 

 www.getopenoffice.org/

templates.html/

 

)

• galerija sliåica postoji, ali je mnogo maça

• neke funkcije za sortiraçe (u verzijama za azijsko træiãte) 

• izvesni filtri datoteka, ukàuåujuñi i filtar za WordPerfect (izrada je u toku).

 

WordPerfect

 

   StarOffice 6 zaWindows ima filtre za WordPerfect; oni su vlasniãtvo nezavisnih 
softverskih kuña, tako da ne mogu biti ukàuåeni u proizvod otvorenog izvornog koda. StarOffice 
6.0 za Unix ne sadræi filtre za WordPerfect. Ipak, filtar tipa libwpd napisan je za aplikaciju Writer 
iz paketa OpenOffice. Slike ekrana su na raspolagaçu na adresi 

 

http://libwpd.sf.net

 

, a oda-
tle se preuzima i materijal. Libwpd je generiåka biblioteka za uvoz (i eventualno izvoz) datoteka 
iz WordPerfecta u druge aplikacije.

Izgled pojedinih prozora donekle se razlikuje. Neka poàa za potvrdu nalaze se na razliåitim 
mestima, ali su raspoloæive moguñnosti iste.

U okviru OpenOfficea razvijaju se i programi za operativne sisteme razliåite od Solarisa, 
Linuxa i Windowsa.

O moguñnostima programa moæete saznati na adresi 

 

allfeatures@openoffice.org

 

. Na 
ovu ili druge liste slaça prijavàujete se na 

 

http://www.openoffice.org/mail_list.html

 

.

 

OpenOffice na drugim platformama

 

Projekti prerade koda programa OpenOffice tako da radi na drugim platformama u toku su veñ 
duæe vreme. U vreme kada je pisana ova kçiga, najviãe paæçe je privukao projekat prevoœeça 
na Macov OS X. U maju 2002, OpenOffice.org je izdao ranu razvojnu veziju “Developer 
Build” za Mac OS X, nameçenu programerima koji su upuñeni u razvoj aplikacija za Mac OS 
X. U to vreme, verziju ste mogli preuzeti sa adrese 

 

http://porting.openoffice.org/mac/

ooo-osx_downloads.html

 

. Ova verzija se nalazi i na priloæenom CD-u.
Informacije o drugim projektima prerade koda potraæite na adresi 

 

http://porting.open-

office.org/

 

.

 

Ãabloni i ostali dodaci OpenOfficea

 

Sa OpenOfficeom se ne dobijaju svi ãabloni iz StarOfficea. Ipak, na Web strani Travisa Bauera, 

 

www.ooextras.org

 

, postoji mnoãtvo ãablona i drugih dodataka. Razvojni tim OpenOfficea 
sastavio je poseban skup ãablona. Oni se nalaze na priloæenom CD-u. Sve ãablone, ukàuåujuñi 
i ãablone autora ove kçige, potraæite na 

 

www.getopenoffice.org/templates.html

 

.
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10 Poglavlje 1 • Uvod u OpenOffice.org

 

Referentna dokumentacija: API i DTD

 

OpenOffice API je dostupan na adresi 

 

www.openoffice.org

 

. Pristupite ovoj lokaciji da biste se 
prikàuåili jednom od projekata OpenOfficea.

 

http://www.openoffice.org/about.html

 

 – na ovoj adresi su opãte informacije o pro-
jektu OpenOffice.org.

 

http://www.openoffice.org/contributing.html

 

 – ovde ñete nañi sve o tome kako 
moæete uåestvovati u projektu.

Da biste dobili DTD, definicije formata dokumenata, idite na 

 

http://xml.openoffice.org

 

. 
zatim na odeàak 

 

Documentation and Resources

 

, i onda pratite vezu prema DTD.
Programeri bi trebalo da posete 

 

http://api.openoffice.org

 

, a svakako: 

 

http://

api.openoffice.org/source/browse/api/devmanual/

 

.

 

Prelazak s Microsoft Officea 

 

Jeste li nezadovoàni korisnik Microsoft Officea? Preœite na OpenOffice! 

 

Deset dobrih razloga   

 

Ako veñ niste, proåitajte odeàak 

 

Deset glavnih razloga za koriãñeçe

 

 

 

pro-
grama OpenOffice.org, 

 

na strani 4.

 

Probna voæça   

 

Sedite za volan. Instalirajte OpenOffice s priloæenog CD-a i pogledajte da li vam 
se sviœa. Napomena: OpenOffice u ovom momentu ne poseduje filtar za uvoz dokumenata iz 
WordPerfecta, ali je izrada u toku. 

 

Konvertujte datoteke   

 

Poånite 
probnu voæçu: testirajte uvoz 
podataka. Priliåno smo sigurni 
da ñe iñi veoma lako. Otvorite 
datoteku iz Microsoft Officea 
birajuñi File > Open i izaberite 
format u padajuñoj listi.

Na slici desno prikazan je 
AutoPilot. Koristite ga za 
uvoæeçe. Neñete rizikovati pri 
eksperimentisaçu jer on doku-
mente ostavàa netaknute i 
samo pravi konvertovane 
kopije.

 

Provedite neko vreme åitajuñi 
priruånike

 

   Upoznajte se s pro-
gramom OpenOffice.org. Proåitajte sledeñe: 

• Poglavàe 5, 

 

Podeãavaçe i saveti.

 

 

• Poglavàe 6, 

 

Poåetak rada u programu Writer

 

.

• Poglavàe 15, 

 

Izrada Web strana

 

.

•

 

Vodiå kroz Calc, 

 

u poglavàu 18.



 

Ãta je novo
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•

 

Izrada nove prezentacije

 

,

 

 

 

strana 570.

•

 

Crtaçe

 

, poglavàe 29.

•

 

Uputstvo za definisaçe izvora podataka

 

, na strani 782. 

 

Ãta je novo

 

OpenOffice.org se priliåno razlikuje od programa StarOffice 5.2. Kàuåno je da viãe nema jedin-
stvene radne povrãine, Schedule Mail i Star Base su nestali, za ãta su dati ozbiàni argumenti. 
O ovim i drugim promenama govoriñemo detaànije u narednim odeàcima.

 

Kompatibilnost i prelazak na OpenOffice

 

StarOffice 5.2, StarOffice 6.0 i OpenOffice vrlo uspeãno funkcioniãu zajedno, pa nema potrebe 
da deinstalirate nijedan. To ne vaæi za StarOffice 6.0 BETA koji se mora deinstalirati pre nego ãto 
instalirate noviju verziju OpenOfficea. 

Datoteke iz verzije 5.2 moæete otvoriti u programu OpenOffice.org, a nove datoteke moæete 
snimiti u formatu 5.2. Tu je i AutoPilot za uvoz veñeg broja datoteka u formatu 5.2.

Prelazak je dobar. Moæda nije potpun, ali se vodi raåuna o podeãavaçu vrednosti parametara 
i o poãti. Pogledajte poglavàe 3, 

 

Prelazak s programa StarOffice 5.2 na OpenOffice.org

 

.

 

Ukloçene aplikacije i moguñnosti programa

 

Nova verzija je jednostavnija i doteranija od donekle preoptereñenog izdaça 5.2. U ovom 
odeàku navodimo kratak pregled izbaåenih moguñnosti i objaãçavamo kako da nadoknadite 
neke.

 

Ãta je ukloçeno ili zaista razliåito

 

Ukloçeno je sledeñe:

• Cela integrisana radna povrãina, ukàuåujuñi Explorer i Beamer, pa samim tim i neke moguñ-
nosti ova dva programa.

• FTP, protokol za prenos datoteka pomoñu Explorera. 

• Image kao posebna aplikacija za doterivaçe slika, iako mnoge moguñnosti joã uvek postoje. 
Jednom ili dvaput pritisnite rastersku sliku u bilo kojoj aplikaciji i pojaviñe se paleta sa alat-
kama i meni programa za obradu slika.

• Mail (program za e-poãtu), iako poãtu i svoj adresar moæete izvesti i povezati s postojeñim 
adresarima programa Netscape ili Outlook.

• Schedule (rokovnik), ukàuåujuñi i Palm Pilot.

• Pravàeçe baza podataka (joã uvek se moæete povezati s raznim bazama podataka pomoñu 
funkcija ODBC, JDBC itd ). 

• Podrãka za izradu okvira na Web stranicama.

• Moguñnost Pack (komprimovaçe), za prezentacije. Ona je ukloçena jer su datoteke tako 
male da ih ne treba komprimovati. Impress Player viãe ne postoji kao zaseban program.
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Uklaçaçe moguñnosti pravàeça baze podataka, osim Adabasa

 

Umesto pravàeça i odræavaça specifiånog StarOfficeovog formata za baze podataka (.

 

sdb

 

), 
sadaãçi sistem za povezivaçe sa izvorima podataka funkcioniãe po uobiåajenim standardima 
za povezivaçe, kao ãto je JDBC, a radi i s bazama podataka kao ãto je dBase. 

I daàe moæete praviti tabele baze podataka, upite i obrasce, iako to donekle zavisi od naåina 
skladiãteça podataka. 

 

Nove aplikacije – ãiroke moguñnosti

 

Evo neãto detaànije liste novina. Malo ãta ñe uticati na primenu specifiånih moguñnosti – izme-
çeni su struktura i potporni elementi da biste lagodnije radili s programom.

 

Format XML   

 

Señate li se pravàeça datoteka u programima Impress i Writer, koje su bile veñe od 
2 MB pre nego ãto ste uopãte i poåeli da radite? S tim je gotovo. U programu Writer sada je 
moguñe praviti datoteke od samo nekoliko kilobajta po strani. Formatiraçe teksta ñe poveñati 
datoteku, ali rezultat je i daàe impresivan. Potrebno je mnogo truda da naåinite datoteku 
veliåine 1 MB.

 

Formati SVG i EPS   

 

Prikazivaçe i uåitavaçe formata EPS je boàe, a moguñe je i izvoziti crteæe 
u format SVG, Scalable Vector Graphics, zasnovan na XML-u.

 

Fontovi   

 

Uraœeni su novi, metriåki TrueType fontovi koriãñeni u Microsoft Windowsu kao 
osnovni fontovi. Zamena fontova je boàa jer se koristi nov savrãeniji algoritam koji ih boàe 
uparuje, åak i na razliåitim platformama. 

 

Podrãka za azijske fontove   

 

Postoji podrãka za Unicode, Ruby text, i podrãka za znakove veliåine 
dva bajta. 

 

Moguñnost obrade slika u svim aplikacijama

 

   Pritisnite bilo koju sliku GIF ili drugi rasterski obje-
kat i pojaviñe se paleta alatki za obradu, koja se prethodno nalazila samo u programu Image.

 

Galerija

 

   Galerija slika i zvukova iz verzije 5.2 preseàena je iz oblasti Explorer/Beamer u meni 
Tools > Gallery. Postojeñoj galeriji moæete dodavati nove ãablone i tako dobiti sopstvene kom-
binacije slika i zvukova, ãto ranije nije bilo moguñe.

 

Ãifrovaçe lozinkom

 

   Format datoteke zasnovan na XML-u podræava ãifrovaçe tekstualnih 
dokumenata i tabela pomoñu lozinke. Lozinke su upisane kao ãifrovane vrednosti. Prilikom sni-
maça podataka u starom binarnom formatu, lozinke nisu ãifrovane. Kada uåitavate dokument 
iz ranije verzije, lozinka ñe biti iznova ãifrovana. 

 

Podrãka za standardni adresar   

 

Viãe nemate stari adresar u formatu 5.2 ali se moæete povezati s 
onim koji sada koristite ili s nekim drugim. AutoPilot, korak po korak, pomaæe da se poveæete 
sa svojim adresarom.

 

Poboàãan izvoz HTML koda

 

   Moæete definisati tip ãifrovaça teksta za izvoz HTML koda; birate 
izmeœu raznih skupova znakova, ukàuåujuñi Unicode. Upotrebite novi okvir za dijalog Charac-
ter Set, u okviru za dijalog HTML Compatibility.

 

Podrãka za MathML formule

 

   Podræava izvoz i uvoz formata W3 XML.

 

Poboàãane komande za isecaçe i umetaçe

 

   Dugme Paste na paleti standardnih funkcija (Func-
tion) ima padajuñi meni iz koga birate da li ñete tekst ili objekat umetnuti u originalnom for-
matu ili u nekom specijalnom. Te opcije dobijate i kada izaberete Edit > Paste Special.
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Boàe komande za opozivaçe i ponavàaçe operacija

 

   Komanda Undo poniãtava mnogo viãe pre-
thodnih postupaka nego ranije. Koliko ñe se postupaka poniãtiti, definiãete birajuñi Tools > 
Options > OpenOffice.org > General.

 

Writer i Web

 

Boàe nalepnice

 

   Postojeñe nalepnice raznih vrsta i tipova moæete modifikovati i snimiti ih kao 
sopstvene formate; ukàuåene su i najnovije specifikacije za nalepnice tipa Avery. 

 

Poboàãana zaãtita odeàaka

 

   Pojedinim odeàcima moæete dodeliti razliåite lozinke. U prethodnim 
verzijama, mogli ste upotrebàavati samo jednu lozinku za sve odeàke. Izaberite Insert > Sec-
tion > Format > Section > Protect Record.

 

Zaãtita lozinkom pri snimaçu izmena dokumenata

 

   Moguñnost Records se najåeãñe koristi kada 
uraœene promene treba da budu vidàive, u sluåaju da viãe àudi obraœuje isti dokument. Izabe-
rite Edit > Changes > Protect Records.

 

Poboàãana numeracija redova  

 

 Redovi se broje iznova na svakoj sledeñoj stranici. Izaberite Tools 
> Line Numbering.

 

Viseña uvlaka

 

   Moæete postaviti negativnu vrednost za (levu ili desnu) uvlaku pasusa i tabela 
i zadati da se prvi red uvuåe nezavisno od uvuåenosti pasusa. Izaberite Format > Paragraph > 
Indents & Spacing. 

Za tabele takoœe moæete postaviti negativne vrednosti za poravnaçe sleva. Tako ih moæete 
poravnati nezavisno od postavàenih margina.  

 

Rastavàaçe reåi na slogove   

 

Da biste definisali minimalan broj znakova u slogu, izaberite Tools 
> Options > Language Settings > Writing Aids.

 

Vertikalno orijentisan tekst

 

   Æelite li da piãete uspravno, duæ ivice stranice? Sada moæete. 
U Writeru postoje verzije alatki za pisaçe teksta iz programa Draw, koje omoguñavaju ver-
tikalan ispis; dostupne su preko menija Show Drawing Tools.

 

Calc

 

Funkcije ROMAN i ARABIC 

 

  Pretvaraju arapske brojeve od 0 do 3999 u rimske i obrnuto.

 

Dodatne nove funkcije

 

:

• MIRR: Izraåunava modifikovanu internu stopu zarade za serije novåanih tokova s kamatnim 
stopama za investicije i reinvesticije. 

• CELL: Pruæa informaciju o sadræaju, formatiraçu i lokaciji odreœene ñelije. 

• ISPMT: Izraåunava kreditnu i investicionu kamatu s konstantnom otkupnom stopom.

• Dodatni modul Analysis: Obezbeœuje novu analitiåku funkcionalnost i poboàãan uvoz iz 
Excela. 

 

Uvoz HTML tabela u radne tabele   

 

Umeñe podatke iz spoànih izvora (kao ãto su vezana poàa ili 
Web upiti). Izaberite Insert > External Data.

 

Opcije za sortiraçe   

 

Odreœuju naåin sortiraça koji zavisi od izabranog jezika. Podrazumevani 
vid sortiraça zavisi od toga koji je jezik izabran kao sistemski. Izaberite Data > Sort > Options.
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Matriåni nizovi

 

   Poboàãana sloæena izraåunavaça. Poveñan je broj elemenata koji se moæe upo-
trebiti u matriånom nizu. U ranijim verzijama, ovaj broj je bio ograniåen na 16.384 elementa po 
matrici, a sada iznosi 512 hiàada elemenata. 

 

Nove opcije za ãtampaçe

 

   

 

Suppress output of empty pages (Izuzimaçe ãtampaça praznih 
strana)

 

. Kad je ova opcija aktivna, neñe se ãtampati strane s praznim ñelijama i bez crteæa. 
Izuzetak su atributi ñelija (kao ãto su ivice ili boja pozadine), i ne raåunaju se kao sadræaj. 

 

Print 
only selected sheets (Ãtampaçe iskàuåivo izabranih strana)

 

. Kada je ova opcija aktivna, 
odaberite komandu All u prozoru za ãtampaçe, i ãtampañe se samo odabrane strane.  

 

Poboàãano vreme izraåunavaça i maçe koriãñeçe memorije

 

   Maksimalna duæina formula je pove-
ñana sa 255 bajtova na 64 KB.

 

Poboàãane operacije  

 

 Fleksibilnije izvodi viãestruke operacije. Ova moguñnost je sada proãirena 
na formule povezane s drugim formulama. Viãestruka operacija ne deluje samo na formulu 
izabranu u okviru za dijalog. Adrese ñelija na koje se formula indirektno odnosi, bivaju zame-
çene u svakoj formuli na koju se naiœe tokom izraåunavaça. 

 

Poboàãano izraåunavaçe procenata   

 

Procentni operator se prepoznaje u formulama i, ako je 
moguñe, rezultat se prikazuje kao procentna vrednost. Procentni operator deli prethodni pod-
izraz sa 100. Ovo pomaæe pri konverziji iz Excela.

Poboàãano prepoznavaçe engleskog formata datuma   Ovo je dodatak formatima koji su podeãeni 
u okviru operativnog sistema, prilikom uvoza tekstualne datoteke u Calc. Omoguñava da 
uvezete datume u formatu kao ãto je 12-Mar-03 nezavisno od formata koji koristi sistem. 
Izaberite File > Open > Text filter.

Poboàãan uvoz i izvoz ãesnaestobitnih tekstualnih datoteka po standardu Unicode   Izaberite File > 
Open ili File > Save As i odaberite format Text CSV.

Poboàãan prikaz preloma redova   Reãava problem razliåitog preloma redova na odãtampanom 
dokumentu i na ekranu, kada izaberete opciju za poravnaçe teksta u ñelijama. Ukoliko prime-
nite ovu opciju, na ekranu se prikazuje prelom redova kao i u odãtampanom dokumentu.  

Prelom teksta u ñeliji   Ova opcija se koristi zajedno sa opcijom Line Break.

Pristup bazi podataka i pravàeçe izvora podataka
Viãe ne moæete praviti nove baze podataka, osim sa Adabasom. Zato moæete praviti izvore 
podataka – veze sa uskladiãtenim izvorima podataka, tj. s neåim jednostavnim kao ãto je 
adresar, radna tabela ili tekstualna datoteka. Sa standardnim bazama podataka kao ãto je Oracle, 
moæete se povezati pomoñu JDBC-a. Pogledajte poglavàe 35. 

Poveæite se sa izvorima podataka umesto da ih sami pravite   Umesto da pravite i odræavate 
specifiåni StarOffice format baze podataka (.sdb), OpenOffice moæe da se poveæe s mnogo 
raznovrsnih izvora podataka, i da svim komponentama obezbedi pristup podacima. 

Upravàaçe   Moæete kopirati tabele i upite iz viãe izvora podataka i kopirati upite kao tabele.  

Uvoz baza podataka iz verzije StarOffice 5.2 (ili starijih)   AutoPilot za uvoz baze podataka uskla-
diãtiñe postojeñe upite, obrasce i izveãtaje iz StarOfficea u novu konfiguracionu datoteku pod 
imenom DataAccess.xml. Dokumenti obrazaca ñe se uskladiãtiti kao i obiåni dokumenti.
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Dodeàivaçe tabele iz baze podataka kombinovanim ili obiånim listama   Preuzmite podatke iz odre-
œenog poàa.

Nove opcije za obrasce   Komande Before reloading izvrãavaju se pre ponovnog uåitavaça 
obrasca. Komande Before unloading izvrãavaju se neposredno pre snimaça gotovih obrazaca. 

Obrada indeksa u tabelama   Ova komponenta je kompletno preraœena. Novo dugme, Index 
Design, na paleti Table Design, omoguñava da samo jednim pritiskom pristupite okviru za dija-
log Indexes. 

Podrãka za komplet znakova UTF-8   Ova podrãka ne vaæi za ADO izvore podataka (koji nemaju 
komplet znakova), ni za dBase izvore podataka. 

Draw, Impress i moguñnosti za obradu slika
Rotiraçe metadatoteka   Nekada ste mogli da rotirate samo bit mape, ne i metadatoteke. Sada 
moæete.

Maksimalna veliåina keã memorije   Postavite gorçu granicu (u KB) za ukupnu veliåinu keã 
memorije nameçene grafici. Izaberite Tools > Options > OpenOffice.org > General.

Vertikalan tekst   U Writeru sada postoje vertikalne verzije sve tri alatke za pisaçe teksta iz pro-
grama Draw. Dostupne su i preko menija Show Drawing Tools.

Opcije za ãtampaçe grafike i prelivi   Izaberite Tools > Options > OpenOffice.org > Print i doñi 
ñete do sledeñih novih opcija:

• Reduced Transparency:  sve providne objekte tretira kao neprovidne. 

• No transparency:  potpuno uklaça providnost.

• Reduce gradients:  smaçuje broj koraka preliva, radi lakãeg ãtampaça. 

• Reduce bitmaps:  ãtampa providne bit mape u maksimalnoj rezoluciji (u taåkama po inåu).

Izvoz formata EPS i SVG   Oba formata se lako dobijaju izvozom iz programa Draw.

Prateñi kompakt diskovi
Uz kçigu dobijate dva CD-a. Na CD-u OpenOffice.org 1.1 nalaze se najnovije verzije program-
skog paketa za Windows i Linux. Uputstva za instaliraçe potraæite u datoteci sadrzaj.txt.

Drugi CD OpenOffice.org 1.0.1, sadræi programski paket opisan u kçizi, ali i mnogo dopun-
skih datoteka koje su napravili izuzetno talentovani i posveñeni ålanovi zajednice OpenOffice.org.

Na disku se nalaze:

• animirani uvod u OpenOffice.org

• prikazi OpenOfficea na Internetu

• uputstvo za instaliraçe i podeãavaçe OpenOfficea

• instalacione datoteke za operativne sisteme Windows, Linux® i Solaris™,

• beta verzija za Mac® OS X

• dodatni reånici
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• animirani vodiå za korisnike koji prvi put rade u programu Writer

• dodatna dokumentacija

• razvojni put OpenOfficea

• primeri i ãabloni koje su napravili ålanovi zajednice OpenOffice.org, ukàuåujuñi datoteke 
sa lokacije http://www.ooextras.org

• izvorni kôd paketa OpenOffice.org 1.0.1

• Adobe Acrobat Reader® 

• Licence za OpenOffice.org: LGPL (GNU Lesser General Public License) i SISSL (Sun 
Industry Standards Source License)

• Razne datoteke u vezi sa CD-om

Napomena – Potpune informacije o instaliraçu pronañi ñete u poglavàu 2.

PrenticeHall PTR, Solveig Haugland i Floyd Jones posebno se zahvaàuju Louisu Suarez-
-Pottsu, Chrisu Herrnbergeru, Joshu Berkusu, Justinu Cliftu, Samu Hiseru, Scottu Carru i Tra-
visu Baueru, jer su s posebnim trudom sastavili CD OpenOffice.org 1.0.1 i nesebiåno ga ustupili.

Da biste saznali viãe o projektu OpenOffice.org, posetite lokacije http://www.openof-
fice.org i http://www.getopenoffice.org.


