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Ãta se nalazi u dodatku

 

Ova kçiga je nameçena smrtnicima – ne programerima – i ograniåenog je obima. Zbog toga 
u çoj ne opisujemo detaàno postupak pisaça makroa.

Ipak, ovaj dodatak ñe vas usmeriti na pravu stranu jer sadræi:

• smernice za pronalaæeçe dodatnih informacija (sledeñi odeàak)

• kratak uvod u makroe

• uvod u okruæeçe za pisaçe makroa, reãeça za neke probleme, i savete.

 

Napomena – 

 

Neposredno pre nego ãto smo ovu kçigu poslali u ãtampu pojavila se podverzija 643. 
U glavne novine spada snimaå makroa i moguñnost ãtampaça u originalnom formatu PDF. Pose-
tite lokaciju 

 

http://www.openoffice.org/dev_docs/source/643/release_notes.html

 

 

 

na kojoj ñete pronañi viãe informacija i s koje moæete preuzeti podverziju 643.

 

Makroi iz programa Excel   

 

OpenOffice i StarOffice ne mogu da otvore makroe iz programa Excel. 
Razlog za to je Microsoftov vlasniåki programski jezik koji ne koriste ni kompanija Sun ni pro-
grameri koji piãu otvoreni kôd. Ako vam trebaju Excelovi makroi, morate ponovo da ih napiãete.

 

Pronalaæeçe makroa i podataka o makroima

 

Programeri OpenOfficea su se mnogo potrudili oko makroa. Ono ãto vam je na raspolagaçu, 
zaista je sveobuhvatno:

• Osnovni izvor je uputstvo koje su napisali programeri, a nalazi se na adresi 

 

http://

api.openoffice.org/basic/man/tutorial/tutorial.pdf

 

. Taj dokument je napisan 
za StarOffice 5.2, ali je i daàe primenàiv.

• Na adresi 

 

www.openoffice.org

 

 pronañi ñete ceo API – programski interfejs aplikacije (gra-
matiku, tj. naåin pisaça makroa). Tu se moæete i prijaviti na liste slaça za korisnike i pro-
gramere. Posebno pogledajte sledeñe:

• Konkretan API, koji vam moæda neñe biti u potpunosti koristan: 

 

http://api.open-

office.org/common/ref/com/sun/star/module-ix.html

 

•

 

http://api.openoffice.org

 

 

•

 

http://framework.openoffice.org

 

•

 

http://api.openoffice.org/documentation_guide.html

 

• Programeri bi trebalo da proåitaju uputstvo za programere:

•

 

http://api.openoffice.org/source/browse/api/devmanual/

 

• Prezentacija Useful Macros Andrewa Browna nalazi se na adresi

 

 http://www.darwin-

wars.com/lunatic/bugs/oo_macros.html

 

.

• Pomoñ i opis postupaka pronañi ñete na lokaciji 

 

http://home.nikocity.de/sysentw/

FAQ/SO-FAQ_English_Version/Answers/answers_9.html

 

.

• Kolekciju makroa i ãablona koja se stalno dopuçuje pronañi ñete na adresi

 

www.ooextras.org

 

.



 

Osnove makroa

 

863

 

OORG

 

, November 21, 2003 10:29 am
Dodatak_OORG.fm, 863 str.

 

• Posetite stranu liste slaça 

 

http://www.openoffice.org/mail_list.html

 

 i pretraæite 
arhivu poruka korisnika i programera (potraæite reå “macro” ili neku drugu kàuånu reå). 
Ako ne pronaœete ono ãto vam treba, prijavite se na odgovarajuñu listu (verovatno za kori-
snike, a moæda i za programere) i postavite pitaçe.

Uz navedeno, proåitajte uputstva na ugraœenom sistemu za pomoñ. Pronañi ñete primer 
makroa za svaku funkciju.

 

Osnove makroa

 

Makroi su mali programi za objavàivaçe odreœenog zadatka, napisani na jeziku specifiånom za 
OpenOffice. Makroi mogu otvarati datoteke kada obavàate odreœeni zadatak, mogu obraœivati 
podatke ili na raåun vaãe bake kupiti gomilu igraåaka za maåku. Znaåi, makroi rade gotovo sve 
ãto poæelite. 

Moæete ih povezati s dogaœajima, recimo s pritiskaçem tastera miãa ili s postavàaçem 
kursora u poàe, a moæete ih i direktno pokretati.

Na raspolagaçu vam je i mnogo postojeñih makroa (slika A-1), a za svaki postoji pomoñ 
sa opisom makroa.

 

Slika A-1   

 

Postojeñi makroi koje moæete koristiti.

Makro moæete napraviti i sami, u prozoru za pisaçe makroa. Na slici A-2 dat je kôd makroa 
koji, kada umesto taåkica stavite odgovarajuñe vrednosti, iz uåitanog dokumenta napravàenog 
u programu Draw ili Impress, izvozi jednu stranu crteæa u formatu 

 

wmf.

 

 Ovaj makro se nalazi 
u arhivi poruka iz diskusionih grupa za OpenOffice.

 

Slika A-2   

 

Makro koji izvozi crteæ iz programa Draw ili Impress u format .

 

wmf

 

.

 

XDrawPage thePage = ...;

  String Url = ...;

  Object xPorterService =

  xMSF.createInstance("com.sun.star.drawing.GraphicExporterFilter");

  XExporter xPorter = (XExporter)

  UnoRuntime.queryInterface(XExporter.class, xPorterService);

  XFilter xFilter = (XFilter) UnoRuntime.queryInterface(XFilter.class,

  xPorterService);

  XComponent xComp = (XComponent)

  UnoRuntime.queryInterface(XComponent.class,thePage);
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  xPorter.setSourceDocument(xComp);

  PropertyValue propertyvalues[] = new PropertyValue[2];

  propertyvalues[0] = new PropertyValue();

  propertyvalues[0].Name = "FilterName";

  propertyvalues[0].Value = "WMF";

  propertyvalues[1] = new PropertyValue();

  propertyvalues[1].Name = "URL";

  propertyvalues[1].Value = Url;

  xFilter.filter(propertyvalues);

 

Koriãñeçe makroa iz ranijih verzija programa i iz drugih programa

 

Uopãteno, makroi iz StarOfficea 5.1 i stariji makroi konvertuju se ili su podræani u OpenOfficeu 
1.0. Makroi iz StarOfficea 5.2 trebalo bi da funkcioniãu i zahtevaju samo male izmene.

Novi format datoteka XML zahteva nov editor dijaloga s potpuno razliåitim formatom. 
Zbog toga se u OpenOfficeu 1.0 ne mogu koristiti makroi iz StarOfficea 4.0 i 5.x. Sve dijaloge 
ñete morati da napiãete od poåetka.

VBA makroi se ne mogu automatski konvertovati u StarBasicove makroe.
Makroi u dokumentima iz Microsoft Officea ne mogu se pokrenuti u OpenOfficeu 1.0. Izvorni 

kôd Microsoftovog VBA makroa 

 

moæete

 

 pregledati kada otvorite Microsoftov dokument (otvo-
rite dokument i odaberite Tools > Macro), ali makroi ñe biti iskàuåeni postavàaçem u komentar.

 

Upoznavaçe s programom

 

Za ovaj zadatak trebañe vam oko deset minuta, a pomoñu çega ñete videti kako program 
funkcioniãe.

 

1

 

Odaberite Tools > Macro.

 

2

 

Pritisnite dugme Organizer.

 

3

 

U prozoru Macro Organizer pritisnite karticu Libraries (biblioteke).

 

4

 

Pritisnite dugme New i dajte novoj biblioteci ime 

 

GuidedTour

 

. Pritisnite OK.

 

5

 

Pritisnite karticu Modules (moduli).

 

6

 

Pogledajte listu Module; biblioteka GuidedTour i podrazumevani modul Module1 prikazani 
su abecednim redom na listi modula.

 

7

 

Pritisnite dugme New Module (nov modul). Novom modulu dajte ime GuidedModule i pri-
tisnite OK. (Modul je naåin grupisaça makroa, a biblioteka grupiãe module.)

 

8

 

Pritisnite dugme Close u prozoru Macro Organizer.

 

9

 

U glavnom prozoru Macro pronaœite biblioteku GuidedTour. Izaberite modul GuidedModule 
koji ste napravili.

 

10

 

Pritisnite dugme Edit.

 

11

 

Otvoriñe se prozor Basic za pisaçe i meçaçe makroa.

 

12

 

Pritisnite F1 da biste otvorili pomoñ za izradu makroa. Pritisnite karticu Index i odaberite 
pomoñ za operator oduzimaça (znak minus). U desnom panou ñe se pojaviti odgovarajuña 
datoteka pomoñi (slika A-3). 
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Slika A-3   

 

Pomoñ za izradu makroa.

 

13

 

Kopirajte primer makroa iz sistema pomoñi u prozor za pisaçe makroa koristeñi komande 
Copy i Paste. Pri tom obriãite makro Main iznad umetnutog primera. Pogledajte slike A-4 
i A–5.

 

Slika A-4   

 

Kopiraçe primera makroa iz sistema pomoñi u prozor za obradu makroa.

 

14

 

Pritisnite ikonicu Single Step 
na paleti Macro pri vrhu 
radnog prostora.
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15

 

Ponovo pritisnite ovu ikonicu za svaki red koda makroa. Pritisnite odgovarajuñe dugme u 
okvirima za dijalog koji se otvaraju. Obratite paæçu na poruke koje se pojavàuju na dnu 
prozora (slika A-5).

 

Slika A-5   

 

Izvrãavaçe makroa korak po korak.

 

16

 

Obriãite primer ExampleSubtraction1 tako ãto ñete obrisati prva tri reda, od Sub do End Sub.

 

17

 

Izmenite ostatak koda makroa. Dodajte joã jednu vrednost i promenite zavrãni red sa iskazom 
Print:

 

iValue3 = 7

Print iValue1 – iValue2 + (iValue1 * iValue3)

End Sub

 

18

 

Snimite makro (odaberite File > Save).

 

19

 

Ponovo pokrenite makro. U okviru za dijalog biñe ispisana vrednost 30.

 

Prozor za obradu makroa

 

Na slici A-6, prikazano je integrisano razvojno okruæeçe (engl. 

 

integrated development envi-
ronment

 

 – IDE) u kom moæete meçati makroe i pristupati çihovim funkcijama. (Odaberite 
Tools > Macro i makro, pa pritisnite Edit.)

Da biste iz jedne biblioteke preãli 
u drugu, odaberite biblioteku s liste 
na levom kraju palete Macro.

Da biste u razvojnom okruæeçu preãli u drugi modul, pri-
tisnite jeziåak odgovarajuñeg modula na dnu radnog prostora.

Ukoliko hoñete da vidite drugi makro, potraæite ga u odgo-
varajuñem modulu pomerajuñi sadræaj naviãe ili naniæe.
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Slika A-6   

 

Radni prostor za obradu makroa.

 

Opcije za podeãavaçe makroa

 

Pogledajte 

 

Zadavaçe opcija za StarBasic makro

 

 na strani 134.
Odaberite Tools > Options > Browser > HTML i opciju StarBasic. Ovu opciju morate oda-

brati pre nego ãto poånete pisaçe skripta koji hoñete da snimite u HTML dokumentu.
Basic skriptovi moraju biti u zaglavàu HTML dokumenta. Kada dokumentu dodate makro, 

on ñe se pojaviti u izvornom kodu HTML dokumenta (u zaglavàu) sa sledeñom sintaksom 
(u primeru se koristi makro koji ispisuje tekst “Hello World”): 

 

<HEAD>
(dodatni sadræaj, ako postoji)
<SCRIPT LANGUAGE="STARBASIC"> 
<!-- 

Pritisnite dugme
Breakpoint da biste u

makro ubacili taåku od koje
ñe se makro izvrãavati

korak po korak.

Pritisnite Single Step da biste
makro izvrãili korak po korak.

Aktuelna biblioteka je
prikazana ovde.

Pritisnite Save Source As
da biste makro snimili
u odreœenu datoteku.

Biblioteka i modul su
navedeni ovde.

Komande su ispisane
zelenom bojom, vrednosti su

crvene, komentari su sivi, a
standardne Basic komande

su plave.

Pritisnite dugme Macros da biste otvorili
prozor Macro; pritisnite Modules da biste

upravàali modulima i bibliotekama.

Pritisnite dugme Object Catalog da biste otvorili
prozor Objects u kom moæete organizovati

makroe i postavàati reference na çih.

Pritisnite dugme Run da biste
izvrãili prvi makro u modulu.

Pritisnite Stop da biste
zaustavili makro koji se izvodi.

Aktuelni moduli su
prikazani ovde.
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’ $LIBRARY: library_name 
’ $MODULE: module_name 
Sub test 
msgbox "Hello World" 
End Sub 
// --> 
</SCRIPT>
</HEAD> 

 

Organizovaçe makroa

 

Ako hoñete odmah da snimite nekoliko makroa, samo napred. Snimite ih u podrazumevanu 
biblioteku (

 

Standard

 

) i ne morate obrañati paæçu na informacije koje slede. Meœutim, ako ñete 
koristiti mnogo makroa, dobro bi bilo da proåitate ovaj odeàak i makroe organizujete u zavi-
snosti od çihove funkcije.

 

Kako su makroi organizovani

 

Radno okruæeçe programa nije naroåito zgodno za brzo i jednostavno snimaçe makroa. 
Makroi su kategorizovani tako da imaju putaçe: jedan ili viãe makroa smeãteno je u modul koji 
se nalazi u biblioteci, a biblioteka se nalazi u datoteci. 

Ako ste koristili makroe u drugim programima, åuvaçe makroa u strukturi stabla – biblio-
teka/modul/makro – moæe vam delovati åudno i nepotrebno komplikovano kada se uporedi s 
jednostavnim snimaçem datoteke makroa bilo gde. 

Snimàene makroe åuvajte u modulima u standardnoj biblioteci (

 

Standard

 

), ili napravite nove 
biblioteke. Svoje makroe ne moæete dodavati nijednoj drugoj postojeñoj biblioteci, kao ãto je, na 
primer, CreateReport (mada dokumentu moæete dodati bilo koji makro iz bilo koje biblioteke).

Slika A-7 prikazuje prozor Macro (odaberite Tools > Macro). U çemu se vidi kako su orga-
nizovani makroi koji su smeãteni u biblioteci Standard.

 

Slika A-7   

 

Organizacija makroa u prozoru Macro.

 

Preporuke za organizovaçe makroa

 

Obratite paæçu na sledeña ograniåeça.

Datoteka makroa – makroi se 
snimaju u datoteku; 
podrazumevana datoteka je 
soffice.sbl. 

U bibliotekama su grupisani 
moduli s makroima. Moæete 
praviti nove biblioteke ili module 
dodavati podrazumevanoj 
biblioteci Standard.

Svaki modul sadræi jedan 
ili viãe makroa. Ime makroa. 
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Viãe od jednog makroa u modulu   

 

Kada za izvoœeçe makroa korak po korak koristite ikonice 
Step i Run s palete Macro, biñe pokrenut samo prvi makro u modulu, a to moæda nije makro koji 
hoñete da izvedete. 

 

Ograniåeçe veliåine   

 

U jednom modulu moæe biti najviãe 64 KB koda.

 

Pronalaæeçe makroa koji ñete dodati dokumentu   

 

Veñina opcija za ubacivaçe makroa omoguñava 
da makro odaberete iz standardne biblioteke i drugih biblioteka, i iz dokumenta u kom se tre-
nutno nalazite, ali ne i iz drugih dokumenata koje ste napravili. Imajte to na umu kada odluåu-
jete gde ñete smestiti makroe.

Na osnovu reåenog, biñe vam mnogo lakãe ako se pridræavate sledeñih saveta:

• Ukoliko pravite makroe koje ñe koristiti viãe àudi, ili ako ñete ih pokretati iz drugih doku-
menata, napravite jednu ili viãe biblioteka za svoje makroe (proåitajte sledeñi odeàak). 
Nemojte ih dodeàivati samo jednom svom dokumentu.

• Napravite nov modul za svaki makro koji piãete (proåitajte odeàak 

 

Izrada novog modula

 

 
na sledeñoj strani).

 

Izrada nove biblioteke

 

1

 

Pritisnite ikonicu Modules na paleti Macro.

 

2

 

U prozoru Macro Organizer pritisnite karticu Libraries.

 

3

 

Pritisnite dugme New da biste otvorili prozor New 
Library (slika A-8).

 

Slika A-8   

 

Izrada nove biblioteke u poàe Name.

 

4

 

Unesite ime u okvir za dijalog New Library.

Da bi nova biblioteka bila posebna datoteka u direktorijumu 

 

office/basic

 

 snimite 
je tako ãto ñete pritisnuti ikonicu Save Source As s palete Macro. Ako to ne uåinite, 
biblioteka ñe biti saåuvana u datoteci 

 

soffice.sbl

 

. Pored toga, makroi koji su saåu-
vani kao posebne datoteke neñe biti automatski uåitani prilikom pokretaça programa 
– morañete da ih aktivirate ruåno (tako ãto ñete pritisnuti Run u prozoru Macros) ili 
koriãñeçem drugog makroa. 

 

5

 

Pritisnite OK.

Zanemarite sve biblioteke
osim biblioteke Standard i

onih koje ste sami napravili.

Pritisnite dugme Edit da 
biste otvorili prvi modul u 
biblioteci koja je odabrana 
u integrisanom razvojnom 
okruæeçu.

Pritisnite dugme New 
da biste napravili novu 
biblioteku; ona ñe biti 
postavàena na dno liste.

Ukoliko pored biblioteke nije
navedeno ime datoteke,

biblioteka je smeãtena
u datoteku soffice.sbl.
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6

 

Napraviñete podrazumevani modul Module1 i on ñe biti naveden ispod nove biblioteke na dnu 
liste Module/Dialog. Pritisnite karticu Modules i odaberite novu biblioteku. Oznaåite ime 
biblioteke i preimenujte je tako da odraæava zadatak koji ñe obavàati makro smeãten u çoj.

 

Napomena – 

 

Druge biblioteke sadræe makroe koje moæete povezivati s dogaœajima u hipervezama 

 

i dokumentima. Proåitajte odeàak 

 

Dodavaçe apleta i prikàuånih programa

 

 na strani 429. 

 

Izrada novog modula

 

Nov modul moæete napraviti u prozoru Macro Organizer ili tako ãto ñete u integrisanom razvoj-
nom okruæeçu otvoriti aktuelnu biblioteku.

 

Koriãñeçe prozora Macro Organizer

 

1

 

Pritisnite ikonicu Modules na paleti Macro.

 

2

 

U prozoru Macro Organizer (slika A-9) pritisnite 
karticu Modules.

 

Slika A-9   

 

Izrada novih modula koriãñeçem prozora Macro Organizer.

 

3

 

Odaberite biblioteku kojoj ñete dodati modul.

Module moæete dodavati samo biblioteci Standard i bibliotekama koje ste sami napravili. 
Ako je ime biblioteke bledo, pritisnite ga dvaput. 

 

4

 

Pritisnite dugme New Module.

 

5

 

Unesite ime modula i pritisnite OK.

 

Koriãñeçe integrisanog razvojnog okruæeça

 

1

 

Pritisnite ikonicu Macros na paleti Macro.

 

2

 

Odaberite modul iz biblioteke kojoj hoñete da dodate 
nov modul i pritisnite dugme Edit.

 

3

 

Desnim tasterom miãa pritisnite jeziåak postojeñeg modula i odaberite Insert > BASIC 
Module.

Zanemarite sve navedene
biblioteke osim biblioteke

Standard i onih koje ste sami
napravili. Ukoliko je neka

biblioteka nedostupna,
pritisnite je dvaput da biste je

aktivirali i proãirite stablo da
biste prikazali çene module.

Pritisnite dugme Edit da biste
odabrani modul otvorili

u razvojnom okruæeçu.
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Upravàaçe makroima, modulima i bibliotekama

 

Sledeñe postupke koristite da biste premeãtali module i makroe, meçali im imena, brisali ih 
i izvodili druge sliåne zadatke.

 

Premeãtaçe modula u drugu biblioteku pomoñu prozora Macro Organizer

 

U prozoru Macro Organizer, modul moæete prevuñi iz jedne biblioteke u drugu.

 

1

 

Pritisnite ikonicu Modules na paleti Macro.

 

2

 

U prozoru Macro Organizer pritisnite karticu Modules.

 

3

 

Odaberite modul koji hoñete da premestite. 

Prevucite ga u drugu biblioteku. Linija ñe oznaåiti mesto na koje ñe modul biti postavàen 
kada pustite taster miãa.

 

4

 

Izaberite modul i pritisnite dugme Edit, pa odaberite File > Save.

 

Premeãtaçe makroa i modula koriãñeçem integrisanog razvojnog okruæeça

 

Makroe moæete premeãtati iz jednog modula u drugi komandama Cut i Paste, bez obzira na to 
da li su moduli u istoj biblioteci ili u razliåitim bibliotekama.

 

1

 

Pritisnite ikonicu Macros na paleti Macro.

 

2

 

Odaberite modul i pritisnite dugme Edit.

 

3

 

Izaberite jedan ili viãe makroa, pa ih komandama Cut 
i Paste premestite u nov modul ili biblioteku.

• Da biste odabrali modul u istoj biblioteci, pritisnite odgovarajuñi jeziåak ispod radnog 
prostora.

• Ako hoñete da odaberete novu biblioteku, pronaœite je na listi u gorçem desnom uglu 
radnog prostora.

 

4

 

Odaberite File > Save da biste snimili izmene.

 

Meçaçe imena modula

 

1

 

Pritisnite ikonicu Macros s palete Macro.

 

2

 

Izaberite modul i pritisnite dugme Edit.

 

3

 

Desnim tasterom miãa pritisnite jeziåak postojeñeg modula i odaberite stavku Rename. 
Unesite novo ime na jeziåak.

 

Sakrivaçe modula

 

Modul moæete privremeno ukloniti, a da ga pri tom ne obriãete.

 

1

 

Pritisnite ikonicu Macros na paleti Macro.

 

2

 

Odaberite modul i pritisnite dugme Edit.

 

3

 

Desnim tasterom miãa pritisnite jeziåak modula i odaberite stavku Hide.
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Brisaçe makroa

 

Jedan ili dva makroa najbræe ñete obrisati u prozoru Macro.

 

1

 

Pritisnite ikonicu Macros na paleti Macro, odaberite modul i pritisnite dugme Edit.

 

2 Izaberite odgovarajuñu kategoriju, biblioteku, modul i makro, pa pritisnite dugme Delete.

Ako hoñete da obriãete mnogo makroa iz modula, najboàe je da preœete u razvojno okru-
æeçe i obriãete tekst makroa ili ceo modul.

1 Pritisnite ikonicu Macros na paleti Macro, pa odaberite modul i pritisnite dugme Edit.

2 U prozoru za tekst u razvojnom okruæeçu obriãite tekst svakog makroa. Zapamtite da su 
poåetak i kraj makroa oznaåeni na sledeñi naåin:
Sub ime makroa
End Sub

Brisaçe modula
Sledeñe metode su podjednako brze, razlikuju se samo po navigaciji.

Ako ste sigurni da hoñete da obriãete modul, uåinite sledeñe:

1 Pritisnite ikonicu Modules na paleti Macro.

2 Pritisnite karticu Modules ako nije aktivna.

3 Odaberite modul i pritisnite dugme Delete.

Ukoliko hoñete da pogledate modul pre nego ãto ga obriãete, uåinite sledeñe:

1 Pritisnite ikonicu Macros na paleti Macro, odaberite modul i pritisnite dugme Edit.

2 Desnim tasterom miãa pritisnite jeziåak modula i odaberite stavku Delete.

Izvrãavaçe makroa
Tek kada pokrenete makro, videñete da li ste snimili neãto korisno. 

Napomena – Nemojte se iznenaditi ako se makro prvi put ne izvede kako treba. Ukoliko postoje 
greãke, proåitajte odeàak Otvaraçe i meçaçe makroa na strani 875. U makroe moæete ubaciti i 
prekidne taåke kojima ñete izvoœeçe makroa zaustaviti na odreœenim mestima. One su korisne 
jer moæete proveriti rezultat izvoœeça odreœenog koraka, pa nastaviti izvoœeçe makroa, ili ga 
izvesti korak po korak. Proåitajte odeàak Koriãñeçe prekidnih taåaka za zaustavàaçe makroa 
u odreœenom trenutku na strani 874.

Makro pokrenite na neki od sledeñih naåina.

Dodeàivaçe preåice s tastature makrou
Ako ñete makro koristiti viãe puta a niste ga povezali s dugmetom ili nekim drugim elementom, 
dobro bi bilo da mu u prozoru Configuration dodelite preåicu s tastature. (Viãe informacija o 
dodeàivaçu preåica s tastature pronañi ñete u odeàku Dodeàivaçe preåica stavkama menija, 
na strani 93.)
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1 Preœite u program u kom hoñete da pokrenete makro. 

2 Odaberite Tools > Configure.

3 Ukoliko kartica Keyboard nije otvorena, pritisnite çen jeziåak.

4 Odaberite opciju OpenOffice.org (slika A-10) osim ako ñete preåicu koristiti samo u pro-
gramu Writer. 

 

Slika A-10   Dodeàivaçe preåice s tastature makrou.

5 U doçem levom uglu prozora nalazi se lista Category. Pomerite çen sadræaj dok, otprilike 
na polovini liste, ne ugledate kategoriju OpenOffice.org BASIC Macros. (Prethodna stavka, 
BASIC, omoguñava da preåice s tastature dodate funkcijama kao ãto je Interrupt Macro.)

6 Odaberite stavku OpenOffice.org BASIC Macros i pritisnite znak plus pored çe da biste je 
proãirili i prikazali biblioteke i module u toj kategoriji.

7 Proãirite biblioteku makroa, na primer Standard, pa odaberite modul i makro.

8 Na listi Shortcut keys nalaze se veñ definisane kombinacije koje moæete koristiti za pokretaçe 
makroa, kao ãto se vidi na slici A-10. Odaberite neku kombinaciju tastera za izabrani makro.

9 Pritisnite dugme Modify da biste preåicu povezali s makroom.

10 Pritisnite OK.

Izvoœeçe makroa od poåetka do kraja
Makro moæete izvesti u razvojnom okruæeçu ili u programu u kom ñete ga koristiti ako su ispu-
çeni uslovi za pokretaçe makroa. Na primer, ako je prvi korak za pokretaçe makroa biraçe 
stavke iz menija File, makro moæete pokrenuti bilo gde. Ako je prvi korak u Writerovom doku-
mentu, taj program mora biti otvoren, a çegov dokument aktivan.

Makro ñete brzo pokrenuti na neki od sledeñih naåina.

Na ovoj listi nalaze se veñ
definisane kombinacije

tastera koje moæete
dodeliti makrou.

Odaberite biblioteku,
na primer Standard,

modul i makro kom ñete
dodeliti preåicu.

Ovde je naveden makro
kom je dodeàena

preåica.
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Pokretaçe prvog makroa iz modula
Ovakvo pokretaçe je moguñe samo ako je makro otvoren u integrisanom razvojnom okruæeçu 
(ikonica ñe biti bleda ako nijedan makro nije otvoren). Biñe pokrenut samo prvi makro u aktu-
elnom modulu; u jednom trenutku moæe biti otvoren samo jedan modul i jedna biblioteka. 

1 Otvorite makro u prozoru razvojnog okruæeça.

2 Pritisnite ikonicu Run na paleti Macro. 

Pokretaçe izabranog makroa

1 Pritisnite ikonicu Macros na paleti Macro.

2 U prozoru Macro izaberite biblioteku, modul i makro koji ñete pokrenuti, pa pritisnite Run.

Postupno izvoœeçe makroa
Naæalost, ne postoji program za ispravàaçe greãaka u makroima. Stoga, skript makroa izvedite 
postupno da biste videli ãta se u svakom koraku deãava.

1 Ako u modulu ima viãe makroa, pobrinite se da onaj koji vam treba bude prvi. 

Koristite komande Cut i Paste da biste makro premestili na vrh, ili napravite nov modul (pri-
tisnite desnim tasterom miãa jeziåak aktuelnog modula i odaberite Insert > BASIC Module), 
pa u çega prebacite makro.

2 U razvojnom okruæeçu ili u programu u kom ñete makro koristiti, pritisnite ikonicu 
Single Step na paleti Macro.

3 Makro ñe se izvoditi korak po korak; ponovo pritisnite ikonicu da biste preãli na 
svaki sledeñi red koda. Pritisnite ikonicu Step Back da biste ponovili prethodni korak.

Ako se javi greãka, otvoriñe se prozor razvojnog okruæeça s porukom o greãci i strelicom 
koja pokazuje red s greãkom.

4 Pritisnite ikonicu Stop da biste zaustavili makro pre nego ãto bude izveden do kraja.

Koriãñeçe prekidnih taåaka za zaustavàaçe makroa u odreœenom trenutku
Makrou moæete dodati prekidnu taåku koja ñe ga zaustaviti u odabranom redu. Potom makro 
moæete izvesti korak po korak koristeñi ikonicu Single Step (pogledajte prethodni odeàak).

Napomena – Kada ubacite prekidnu taåku, program proverava ceo makro traæeñi greãke; neñete 
moñi da ubacite prekidnu taåku ukoliko postoje problemi u kodu. Moæda ñete morati da posta-
vite problematiåne redove u komentar da biste mogli da dodate prekidnu taåku.

1 Otvorite makro u razvojnom okruæeçu.

2 Postavite kursor u red od kog hoñete da se sa automatskog izvoœeça makroa prebacite 
na ruåno.

3 Pritisnite ikonicu Breakpoint na paleti Macro.

4 Levo od reda pojaviñe se crveni kruæiñ.

Da biste uklonili prekidnu taåku, ponovo pritisnite ikonicu Breakpoint.
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Otvaraçe i meçaçe makroa
Verovatno ñete morati da podeãavate bar polovinu makroa koje koristite da biste ih popravili 
ili izmenili tako da rade joã neãto. Pored toga, ako ñe joã neko koristiti ili popravàati makroe 
koje ste napravili, dobro bi bilo da im dodate komentare koji opisuju ãta pojedini redovi rade.

Napomena – Program ñe od vas neumorno traæiti lozinku ako pokuãate da meçate postojeñe 
makroe koje ste dobili s programom. Te makroe ne moæete da meçate i verovatno je dobro ãto 
je tako. Moæete ih nepromeçene dodavati dokumentima kao ãto je opisano na sledeñoj strani.

Dodavaçe komentara
Ako redovima koda makroa hoñete da dodate opis, pritisnite Enter da biste dodali nov red 
i poånite ga apostrofom ili velikim slovima REM.

'Ovaj red koda pokreñe animirani GIF na kom se vide 
'dva åoveka koji se maåuju.
Documents.Open( "file:///home/magentaf/gifs/inigo.gif")

Komentari su ispisani svetlo.

Saveti za reãavaçe problema
Kada se tokom izvoœeça makroa javi greãka, poruka o çoj ñe se pojaviti, a u prozoru Basic 
biñe oznaåen red s greãkom. 

Lociraçe problema   Ako imate problem, uvek koristite funkciju Single Step da biste makro 
izveli korak po korak (proåitajte odeàak Postupno izvoœeçe makroa na prethodnoj strani). 
Ukoliko se greãka nalazi pri kraju makroa, dodajte prekidnu taåku.

Postavite u komentar redove koji prave probleme. Ako je red opcioni, ubacite ispred çega 
apostrof da biste ga iskàuåili postavàaçem u komentar. Tekst reda postañe siv, a makro ñe se 
izvoditi bez çega. Ovu tehniku moæete koristiti da biste locirali izvor greãaka.

Makroi koji prave nove datoteke   Ako vam treba makro koji pravi nove datoteke, moæda ñete 
morati da izmenite neke od makroa. Na primer, sledeñi redovi koda nastaju kada napravite novu 
datoteku u programu Writer:

Documents.Open( "file:///home/magentaf/Office/config/new/_05_text.url", "", 
"", "", 0, "file:///home/magentaf/Office/config/new/" )
[Untitled1:1].Activate()

Ukoliko je veñ otvoren nenaslovàen dokument, red ñe biti zabeleæen kao Untitled1:1 i 
dobiñete greãku kada pokrenete datoteku. Program ñe svaku nenaslovàenu datoteku koju otvori 
hteti da nazove Untitled1. Ako se jave greãke, promenite ovaj red koda.

Ne moæete da promenite ime datoteke u “Godiãçi izveãtaj” niti u neko sliåno ime pod kojim 
ñete snimiti dokument; program ñe se pobuniti i prijaviti greãku.

Napomena –  U HTML Editoru postoji funkcija koja omoguñava da napravite hipervezu za otva-
raçe nove datoteke. Mogli biste koristiti çu umesto makroa. Proåitajte odeàak Veze do nove 
datoteke na strani 422.
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Dodavaçe makroa dokumentu
Najåeãñe ñete makroe dodavati drugim dokumentima, na primer Web stranama ili prezentaci-
jama. U HTML Editoru postoji mnogo funkcija koje omoguñavaju postavàaçe hiperveza do 
makroa, i skriptova napisanih na Basicu ili JavaScriptu. Åak i jednostavni makroi, kao ãto je 
otvaraçe nove datoteke i unoãeçe par redova teksta, ili brisaçe redova ili objekata u aktuel-
nom ili nekom drugom dokumentu, biñe efikasni i korisni u dokumentima kao ãto su prezen-
tacije i Web strane.

U tabeli A-1 navedeni su naåini na koje moæete dodati makroe dokumentima i odeàci u 
kojima ñete pronañi viãe informacija. 

Napomena – Veñina funkcija za ubacivaçe makroa omoguñava da dodate makro iz standardne ili 
neke druge biblioteke, ili iz trenutno otvorenog dokumenta, ali ne i iz drugih dokumenata koje 
ste napravili. Ako ne moæete da pronaœete makro koji vam treba, on se verovatno nalazi u 
posebnom dokumentu. Morañete da ga kopirate u modul u standardnoj ili novoj biblioteci, ili 
da napravite modul za çega u trenutno oktivnom dokumentu.

Tabela A-1   Dodavaçe makroa svim tipovima dokumenata

Funkcija Gde se nalaze informacije

Interakcija Efekti interakcije: pokretaçe makroa i viãe od toga, na strani 640

Funkcije obrazaca Poglavàe 36

Hiperveze Koriãñeçe makroa, skriptova i dogaœaja, na strani 431

Preåice s tastature Dodeàivaçe preåice s tastature makrou, na strani 872


